読者です 読者をやめる 読者になる 読者になる

connect 2.0.0alpha1 Released

node.js

connectの2系がリリースされた。結構インターフェース変わってるっぽい。あと気を付けないといけないのがnpmにもあがってて、nodeのバージョンの依存が >= 0.5.0 < 0.7.0 なのでnodeのバージョンが4.xでインストールできないということ。

すでにこういう問題が起きてる。
https://github.com/kcbanner/connect-mongo/issues/11

これpackage.jsonの依存関係に "connect": ">=1.0.3" って書いてあるからconnectの最新を入れようとして 4.x 系だとエラるというものだと思う。

依存モジュールのバージョンの記述には気を付けるべし。