読者です 読者をやめる 読者になる 読者になる

Mac OSX 10.6でRuby 1.9.2のインストールではまった

rbenvで1.9.2を入れようと思ったらはまった。

$ brew install rbenv
$ brew install ruby-build

で.zshrcにこれ書いて

eval "$(rbenv init -)"
$ rbenv install 1.9.2-p290

したけどビルドでエラる。なんか調べてみたらgccの問題らしい

$ ls -l /usr/bin/gcc
lrwxr-xr-x  1 root  wheel  12  6  7  2011 /usr/bin/gcc@ -> llvm-gcc-4.2

llvm-gcc-4.2になってるけど、gcc-4.2にすればいけるっぽいっての見つけて

$ ln -s /usr/bin/gcc-4.2 ~/local/bin/gcc

したらいけた。(~/local/binは/usr/binより優先されるようにパスが通ってる)